forum.webdiplomacy.net

webDip dev coordination forum / public access todo list
It is currently Mon Nov 20, 2017 12:04 am

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Tue Apr 05, 2011 9:21 pm 
Offline

Joined: Tue Apr 05, 2011 9:16 pm
Posts: 3
When I try to sign pops up this error:

Code:
Mailer error: The following From address failed: tomekkuziola@gmail.com



config.php

Code:
public static $mailerConfig = array(
         "From"=> "tomekkuziola@gmail.com",
         /* The e-mail which mail is sent from. This should be a valid e-mail,
         or it may trip spam filters. */
         "FromName"=> "tomekkuziola@gmail.com",
         /* The name being mailed from. */
         "UseMail"=>false,
         /* Use the php mail() function. Either UseMail, UseSendmail or UseSMTP has to be TRUE,
            if you're using e-mail. */
         "UseSendmail"=>false,
         /* Use the sendmail binary, if this is false the variable below is ignored */
         "SendmailSettings"=> array(
               "Location"=>"/usr/sbin/sendmail"
               /* Location of the sendmail binary */
            ),
         "UseSMTP"=> true,
         /* Use SMTP, if this is FALSE the variable below is ignored. */
         "SMTPSettings"=> array(
               "Host"=>"smtp.gmail.com",
               "Port"=>"465",
               "SMTPAuth"=>false,
               /* If this is FALSE the two variables below are ignored */
               "Username"=>"tomekkuziola@gmail.com",
               "Password"=>"my_password"
            ),
         "UseDebug" => false // If this is set to true mail will be output to the browser instead of sent, useful for debugging
      );


Top
 Profile  
 
PostPosted: Tue Apr 05, 2011 11:32 pm 
Offline
Site Admin

Joined: Sat Jun 28, 2008 6:24 am
Posts: 892
I wouldn't use gmail; first off you need to set it up to use TLS, and second it doesn't like automated e-mails and will block them pretty quickly


Top
 Profile  
 
PostPosted: Wed Apr 06, 2011 12:46 am 
Offline

Joined: Wed Oct 08, 2008 12:47 pm
Posts: 726
I use gmail via php-mailer for a site I run, and we haven't had any problems there.
It sends probably 3 emails a day (each to around 75 people) without any issues.

Code:
               "SMTPAuth"=>false,

I'm not certain, but I think this is your problem. You try to send an email through gmail without actually logging in?


Top
 Profile  
 
PostPosted: Wed Apr 06, 2011 9:52 am 
Offline

Joined: Tue Apr 05, 2011 9:16 pm
Posts: 3
new problem:

Code:
Error triggered: fputs() [function.fputs]: send of 26 bytes failed with errno=32 Broken pipe.

This was probably caused by a software bug. If these occur often try enabling error-logging via config.php, and report errors to the official devs for help.



config:

Code:
public static $mailerConfig = array(
         "From"=> "kontakt@konfliktyzbrojne.pl",
         /* The e-mail which mail is sent from. This should be a valid e-mail,
         or it may trip spam filters. */
         "FromName"=> "kontakt@konfliktyzbrojne.pl",
         /* The name being mailed from. */
         "UseMail"=>false,
         /* Use the php mail() function. Either UseMail, UseSendmail or UseSMTP has to be TRUE,
            if you're using e-mail. */
         "UseSendmail"=>false,
         /* Use the sendmail binary, if this is false the variable below is ignored */
         "SendmailSettings"=> array(
               "Location"=>"/usr/sbin/sendmail"
               /* Location of the sendmail binary */
            ),
         "UseSMTP"=> true,
         /* Use SMTP, if this is FALSE the variable below is ignored. */
         "SMTPSettings"=> array(
               "Host"=>"az0023.srv.az.pl",
               "Port"=>"465",
               "SMTPAuth"=> true,
               /* If this is FALSE the two variables below are ignored */
               "Username"=>"ztg99373",
               "Password"=>"password"
            ),
         "UseDebug" => false // If this is set to true mail will be output to the browser instead of sent, useful for debugging
      );


Hosting information:
Quote:
Mail server user name: ztg99373
Incoming mail server: mail.hosting4812739.az.pl
Incoming mail server (SSL) az0023.srv.az.pl
Outgoing Mail Server: mail.hosting4812739.az.pl (server requires authentication) port 25
Outgoing Mail Server: (SSL) az0023.srv.az.pl (server requires authentication) port 465
Supported Incoming Mail Protocols: POP3, POP3S (SSL / TLS), IMAP, IMAPS (SSL / TLS)
Supported Outgoing Mail Protocols: SMTP, SMTPS (SSL / TLS)


Can You show me Yours config?


Top
 Profile  
 
PostPosted: Wed Apr 06, 2011 11:21 am 
Offline

Joined: Wed Oct 08, 2008 12:47 pm
Posts: 726
Someone else might be able to give you a better answer, but if you turn on the mail debug does this issue go away?
I assume it would, since this appears to be a problem with the SMTP connection, but helps to make sure.
Also, enable error reporting then send over the error log.


Top
 Profile  
 
PostPosted: Wed Apr 06, 2011 11:37 am 
Offline

Joined: Tue Apr 05, 2011 9:16 pm
Posts: 3
how can i disable "Validate your e-mail address"?


Top
 Profile  
 
PostPosted: Thu Apr 07, 2011 12:01 am 
Offline

Joined: Wed Oct 08, 2008 12:47 pm
Posts: 726
Code:
         "UseDebug" => false

Set this to true


Top
 Profile  
 
PostPosted: Thu Apr 07, 2011 3:13 am 
Offline
Site Admin

Joined: Sat Jun 28, 2008 6:24 am
Posts: 892
Make sure you've got the latest webDip code (the latest code linked to on the main page of the forum), and then change:
Code:
"SMTPAuth"=> true,

to
Code:
"SMTPAuth"=> true, "SMTPSecure"=>"ssl",


If that doesn't work try using the non SSL/TLS ports and servers


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group