forum.webdiplomacy.net

webDip dev coordination forum / public access todo list
It is currently Thu Nov 23, 2017 10:54 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 

Does you hosting provider have PHP 5.3?
Yes 60%  60%  [ 3 ]
No 20%  20%  [ 1 ]
Not sure 0%  0%  [ 0 ]
I don't host a webDiplomacy server 20%  20%  [ 1 ]
Total votes : 5
Author Message
PostPosted: Fri Jan 14, 2011 12:56 am 
Offline
Site Admin

Joined: Sat Jun 28, 2008 6:24 am
Posts: 892
Dreamhost has had it for a while, and I'd like to be able to use features which came out in PHP 5.3 (for allowing flexibility and plugins it has an especially useful feature called anonymous functions, among other things)

But if it's not out there yet then I can't really put out a version of webDip which depends on it, so I'd be interested to know who has what PHP version. (You can find your PHP version by making a new .php file containing "<?php php_info(); ?>" , and run it on your web server

We currently require 5.2, so the question is whether we can start to bump that up to 5.3 yet


Top
 Profile  
 
PostPosted: Thu Jan 20, 2011 9:59 am 
Offline

Joined: Thu Jan 14, 2010 7:48 pm
Posts: 87
No, I have php 5.2.13 and 5.2.14 .

ah, and the php file should be "<?php phpinfo(); ?>" without the _


Top
 Profile  
 
PostPosted: Thu Jan 20, 2011 1:22 pm 
Offline
Site Admin

Joined: Sat Jun 28, 2008 6:24 am
Posts: 892
How many players does your site have, and has your hosting company said anything about moving to 5.3?


Top
 Profile  
 
PostPosted: Thu Jan 20, 2011 3:18 pm 
Offline

Joined: Thu Jan 14, 2010 7:48 pm
Posts: 87
the first one has 60 active players

the second only 10 at the moment, but it's transitory, and I hope it'll increase soon.



the hosters didn't said anything about moving to 5.3.


Top
 Profile  
 
PostPosted: Sun Jan 23, 2011 8:51 am 
Offline

Joined: Wed Jul 29, 2009 10:22 am
Posts: 841
alexintour wrote:
No, I have php 5.2.13 and 5.2.14.

Maybe thats just the default PHP version, and you can switch the default engine somewhere in your webspace configuration.
I can choose between 4.0, 5.0 and 5.3 using a switch in my webconfiguration.
And I can set a non_default PHP version changing the PHP-suffix (e.g. .php4 will use the PHP-vesion 4, .php53 will use PHP 5.3) or using .htsccess for directory-wide changes.

You should check that too, as 5.0 was the default engine for me too.

Oliver


Top
 Profile  
 
PostPosted: Sun Jan 23, 2011 12:41 pm 
Offline

Joined: Wed Oct 08, 2008 12:47 pm
Posts: 726
Having checked some of them I voted yes, but I've just noticed the one I'm most likely to run webDip on is still on 5.2.16
Given that, I've just changed my vote to 'I don't host' instead.
I suggest we go for the improvements, and would be quite happy not hosting again until my server could again cope.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group